Prime Test 350 Cutting Out

PATGuard 3 Forum

Prime Test 350 Cutting Out

Postby AndyS » Thu May 29, 2014 3:53 pm

My Primetest 350 has been cutting out on me recently.
It only seems to happen when testing PC's in the Class 1 Hand held/IT test.
It will do the visual and Earth Bond test but as soon as it attempts the Insulation test it switches off.
Anyone got any ideas why?

Andy
AndyS
 
Posts: 2
Joined: Thu May 29, 2014 3:49 pm

Re: Prime Test 350 Cutting Out

Postby Amy Lyons » Fri Jun 13, 2014 2:51 pm

Hi Andy S

You might want to try some brand new batteries. are you using rechargeables at the moment? If this doesn't work I'm afraid you may need to return your unit for repair. To arrange this please contact our Service department on 0191 5878739.
Thanks and kind regards

Amy Lyons
Applications Engineer
Test & Measurement Division
Seaward Electronic
User avatar
Amy Lyons
Applications Engineer
 
Posts: 164
Joined: Mon Apr 23, 2012 2:40 pm
Location: Peterlee, UK

Re: Prime Test 350 Cutting Out

Postby AndyS » Fri Jun 27, 2014 1:41 pm

New batteries have solved that problem, however there still appears to be a few glitches. For example, every now and again (even with new batteries) the machine makes a few "bleeps" and reverts the majority of the fieilds to "OK" sometimes wiping the settings .
AndyS
 
Posts: 2
Joined: Thu May 29, 2014 3:49 pm

Re: Prime Test 350 Cutting Out

Postby Amy Lyons » Fri Jun 27, 2014 2:32 pm

I haven't head of this happening with full batteries but by all means get in contact with our Service department to get your unit checked out on 0191 5878739.
Thanks and kind regards

Amy Lyons
Applications Engineer
Test & Measurement Division
Seaward Electronic
User avatar
Amy Lyons
Applications Engineer
 
Posts: 164
Joined: Mon Apr 23, 2012 2:40 pm
Location: Peterlee, UK


Return to Portable Appliance Testing


Who is online

Users browsing this forum: Bing [Bot] and 2 guests

 
 
cron