Battery Life Problems (Primetest 350)

PATGuard 3 Forum

Re: Battery Life Problems (Primetest 350)

Postby HWUGTB » Tue Feb 28, 2012 11:58 am

Jim Wallace wrote:Thanks for the additional information on the tests you have performed. I will pass this on to our development engineers and ask for their comments.


Any update?. This really is causing us problems.
HWUGTB
 
Posts: 11
Joined: Tue Nov 22, 2011 2:29 pm

Re: Battery Life Problems (Primetest 350)

Postby Jim Wallace » Tue Feb 28, 2012 11:04 pm

Thanks for the reminder.... I will try and get some info for you this week.
User avatar
Jim Wallace
Associate Director, Seaward Product and Technology
 
Posts: 124
Joined: Wed Feb 16, 2011 7:35 pm

Re: Battery Life Problems (Primetest 350)

Postby Jim Wallace » Tue Mar 13, 2012 3:37 pm

Hi HWUGTB

I've spoken with our design engineers. The thersholds for the battery icon on the PT350 are:

6.5V icon appears
6.4V icon shows reduced battery capacity
6.3V icon flashes and testing is inhibited

A number of changes have been implemented over the past 12-24 months.

1. The battery contacts were changed to a different material type. The originals had a problem whereby they developed a coating due to a reaction between the battery and contact and this gave the appearance of low battery life. You can check this be cleaning the battery contacts and seeing if the battery icon goes off. Often, simply rotating the batteries (run your hand across them so they rotate in-situ) is enough to remove the surface tarnish.

2. Firmware was updated to reduce the voltage (to those above) at which the icon appeared. We did this because several customers assumed that as soon as the battery icon appeared they batteries where flat and did not appreciate if was a gauge. Latest firmware is on our website.

3. Charger design was changed so that the trickle charge current is increased. Even if the charger incorrectly senses that the batteries are charged (it uses a -ve dV if your interested.....) the trickle charge is sufficient to fully charge the batteries on an overnight charge.
User avatar
Jim Wallace
Associate Director, Seaward Product and Technology
 
Posts: 124
Joined: Wed Feb 16, 2011 7:35 pm

Re: Battery Life Problems (Primetest 350)

Postby HWUGTB » Thu Mar 22, 2012 4:21 pm

Jim Wallace wrote:Hi HWUGTB

I've spoken with our design engineers. The thersholds for the battery icon on the PT350 are:

6.5V icon appears
6.4V icon shows reduced battery capacity
6.3V icon flashes and testing is inhibited

A number of changes have been implemented over the past 12-24 months.

1. The battery contacts were changed to a different material type. The originals had a problem whereby they developed a coating due to a reaction between the battery and contact and this gave the appearance of low battery life. You can check this be cleaning the battery contacts and seeing if the battery icon goes off. Often, simply rotating the batteries (run your hand across them so they rotate in-situ) is enough to remove the surface tarnish.

2. Firmware was updated to reduce the voltage (to those above) at which the icon appeared. We did this because several customers assumed that as soon as the battery icon appeared they batteries where flat and did not appreciate if was a gauge. Latest firmware is on our website.

3. Charger design was changed so that the trickle charge current is increased. Even if the charger incorrectly senses that the batteries are charged (it uses a -ve dV if your interested.....) the trickle charge is sufficient to fully charge the batteries on an overnight charge.


Thanks for checking but Ive done some further investigating and the problem "to me" seems that the firmware is reporting flat battery's and shutting down prematurely.

What I did-

1. Checked and cleaned all the battery terminals / contacts as they did have some "tarnish"
2. Run the PAT tester until it started showing the flat battery symbol and also started shutting down / switching off (during Class 1 earth test).
3. Switched tester back on whilst holding "U" to get into self test area and had a look at the battery voltage in this self test menu. It reported around 6.9V whilst doing the self tests.
4. Took the battery's out and tested them with our battery capacity checker down to 6.3V. They started off around 7V and once they reached 6.3V on a 1 AMP discharge it reported that the capacity was 1244mAH.

I really think there is either a bug in the firmware or that the levels are not 6.3V for a flat battery. Im leaning to a firmware bug tho ;)

Please can you do some testing as we are only getting a handful of tests on a full charge because of this.

Regards
HWUGTB
 
Posts: 11
Joined: Tue Nov 22, 2011 2:29 pm

Re: Battery Life Problems (Primetest 350)

Postby Jim Wallace » Thu Mar 22, 2012 8:56 pm

Are you using the latest firmware version (3.61)?
I'll speak to our development engineers in the morning and ask them to look at the info you have posted.
User avatar
Jim Wallace
Associate Director, Seaward Product and Technology
 
Posts: 124
Joined: Wed Feb 16, 2011 7:35 pm

Re: Battery Life Problems (Primetest 350)

Postby HWUGTB » Wed Mar 28, 2012 11:27 am

yes latest firmware - 3.61

thanks
HWUGTB
 
Posts: 11
Joined: Tue Nov 22, 2011 2:29 pm

Re: Battery Life Problems (Primetest 350)

Postby remedy234 » Wed Apr 18, 2012 5:17 pm

Glad i read this as was going to switch all our testers to these from the ultra reliable workhorses the europa plus.

Not going to bother now tho
remedy234
 
Posts: 51
Joined: Wed Apr 18, 2012 11:04 am

Re: Battery Life Problems (Primetest 350)

Postby HWUGTB » Thu May 03, 2012 1:30 pm

Ok, I think I have got to the bottom of it and it is due to the "reaction between the battery and contact and this gave the appearance of low battery life."

I had cleaned the contacts so expected it to be ok (for a while). However this "tarnish" must give problems quite quickly(within 1 charge).

Now when we use tester we spin batteries any time symbol appears and this then allowed us to run batteries down until there was 129maH (good).

Is there any thing you could do? Maybe send us the newer type contacts so we could swap them out. We are an electronics workshop so this would be no problem for us to do. Its either that or you could do it for us. If not we will be stuck with having to open battery compartment to spin batteries very often .
HWUGTB
 
Posts: 11
Joined: Tue Nov 22, 2011 2:29 pm

Re: Battery Life Problems (Primetest 350)

Postby Jim Wallace » Sun May 06, 2012 2:06 pm

Hi HWUGTB

We changed to battery contact material some time ago when the problem was discovered - we have some metalurgy tests done by one of our local universities and found that the contact material was not what it said on the tin.

Looks like you have the old type contact material.
User avatar
Jim Wallace
Associate Director, Seaward Product and Technology
 
Posts: 124
Joined: Wed Feb 16, 2011 7:35 pm

Re: Battery Life Problems (Primetest 350)

Postby jonathan » Sat May 12, 2012 9:14 am

Jim Wallace wrote:Hi HWUGTB

We changed to battery contact material some time ago when the problem was discovered - we have some metalurgy tests done by one of our local universities and found that the contact material was not what it said on the tin.

Looks like you have the old type contact material.


Would Seaward be willing to offer a free service to replace the contacts if they prove to be these old type, or provide the new contacts for competent owners to replace them themselves?
User avatar
jonathan
 
Posts: 37
Joined: Mon Apr 30, 2012 2:06 pm

PreviousNext

Return to Portable Appliance Testing


Who is online

Users browsing this forum: Bing [Bot] and 3 guests

 
 
cron