Page 1 of 1

Seaward Primetest 300 limited menu

PostPosted: Sun May 10, 2015 3:34 pm
by Gareth JD
Hi Folks,
I have just bought a second hand ( like new) Seaward Primetest.
It came with carry case,' kettle lead' and instructions.
No other kit was included, I have a Belkin Bluetooth dongle that talks to my PC from the tester.
A new battery charger was bought with new rechargeable batteries.
However on switching on there are only 4 options on the menu screen, I am unable to access
any test functions be them manual or automatic.
The screen has on it Boot 1.05 in top left corner under the date, is this anything?
Does this tester require an operating system to be installed before all menus can be accessed or
is it somehow locked out?
Any help would be greatly appreciated,
Thanks, Gareth.

Re: Seaward Primetest 300 limited menu

PostPosted: Tue May 26, 2015 2:49 pm
by Graeme
Not sure about the 300 as I have the 350. If you can get into the user options, there are settings for different users, perhaps these settings need to be adjusted. Just a thought!

Re: Seaward Primetest 300 limited menu

PostPosted: Thu Jun 11, 2015 2:21 pm
by Amy Lyons
Hi Gareth JD

I'm not sure what the 'Boot 1.05' message means. You may have inadvertently powered up in in a service mode. You could try updating the firmware available from our website. Please se below instructions also.

http://www.seaward.co.uk/downloads/025-how-to-update-the-primetest-350-firmware.pdf

http://www.seaward.co.uk/seaward-downloads?id=Firmware%20Updates