Page 1 of 1

PatGuard 2 on Windows 7 64 bit

PostPosted: Wed Oct 23, 2013 5:01 pm
by david lane
I am trying to do network installation for PATguard 2 on Windows 76 64 bit and have installed the sql 2008 native client and am not able to open the database as it is comming up with Not suitable providers are installed , The following providers failed to load sql server or oracle. We have older machines with windows xp that run fine( but we are in the process of replacing all our xp machines) and we are able to navigate to the sql server database fine.

I then need to set up the connect to the database via our sql server. (Which I can test a data source connection too fine)

We are running version 2.0.3, I have looked for the update to 2.1, as I thought this might help, but not able to find this either.

Any help would be great.

Re: PatGuard 2 on Windows 7 64 bit

PostPosted: Wed Oct 30, 2013 10:38 am
by david lane
Had to have v2.2 installed but now getting unable to open up database as it is not deleted or exist.
Our sql can open up it up and gets a prompt to choose the sql data provider which i am not getting having installed sql server 2008 express with full installation. Also getting a licence module error message too when using the netseup.msi.

Any clues would be helpful.

Re: PatGuard 2 on Windows 7 64 bit

PostPosted: Tue Nov 26, 2013 10:20 am
by david lane
I have sorted this out.

You need to make sure that the sql database you are using has a windows security group or the windows account you are using has permissions directly on the database that it is trying to access as Windows 7 using windows authentication to access the sql database as well as the sql credentials.

Hope this helps anyone else with this issue.