Page 1 of 1

Seaward 350 mains failure

PostPosted: Fri Dec 14, 2012 12:11 pm
by StOuennais
Hi, I carried out a RCD test for the first time yesterday, but I was not happy with the results, as it tripped the main RCD in the wall socket, so left RCD test until I had more info, I reset the Wall RCD and I continued with an IEC lead test which was ok I then tried to do a portable appliance Class II test all ok until the load test where the 350 gave me and Alert box saying "Mains Relay Safety test has failed Code 0400" " Please re-check the incoming mains supply" Press the Green Start key to re-start.
I have checked all fuses 1 in the mains lead (Black round connector lead) and both fuses in the battery compartment and all are OK. but when I re-try the test I get the same Alert. so I cannot do any testing which requires the mains to be present.
Has anyone any ideas.
Regards
Mitch

Re: Seaward 350 mains failure

PostPosted: Mon Dec 17, 2012 4:29 pm
by Amy Lyons
Hi StOuennais
I'm afraid it seems that there is an issue with one of the relays inside of your tester meaning it will have to be sent back for repair. Please contact our Service department on 0191 5878739 to arrange this.
It would be very unlikely that performing an RCD trip time test would cause this issue on the tester.
For performing RCD trip time tests using the PT350 please use the NTB-1 isolater designed to allow testing of RCDs without tripping the supply RCD.

Re: Seaward 350 mains failure

PostPosted: Thu Dec 27, 2012 5:37 pm
by StOuennais
Hi Amy,

I had been carrying out PAT Tests all day without any problems what so ever, I then started the RCD test, which tripped the wall RCD, it was after this that the 350 started indicating the fault mentioned earlier.

Regards
Mitch