Primetest 250 RCD test results

PATGuard 3 Forum

Primetest 250 RCD test results

Postby cpjelectrics » Sun Sep 23, 2012 6:22 pm

I have been testing 4 extension leads with RCD plugs installed. On all of them I received high readings for a 30mA trip on both sides of the sine wave (0deg & 180deg). A couple were over 200ms so considered a fail. I became suspicious about this so I tested the same RCD plugs using my Meggar 1720 and had totally different results. With the Megger all were in the <20ms results hence acceptable.

My test setup with the Primetest 250 was :-

Connect portable RCD plug to a power socket
Connect Primetest 250 to extension lead with the mains inlet socket

ie as per the manual

Have I carried out the test incorrectly ?
Posts: 2
Joined: Sun Sep 23, 2012 6:10 pm
Location: Wokingham,Berkshire,UK

Re: Primetest 250 RCD test results

Postby jonathan » Thu Oct 04, 2012 4:34 pm

You may want to check the voltage used for the test, if that is configurable, as on my PT250 I need to set the voltage to 250 when testing surge-protected 4-way extensions; they don't always fail if I forget and leave it at 500v, but half of them will only pass when it is set to 250v.
User avatar
Posts: 37
Joined: Mon Apr 30, 2012 2:06 pm

Re: Primetest 250 RCD test results

Postby Grizzly » Thu Oct 04, 2012 11:08 pm

jonathan: surely you're talking about IR test settings?
The OP is talking about the RCD test. The IR test voltage should have no bearing on the RCD test.
C&G 2377 -01 & -02
User avatar
Posts: 114
Joined: Tue Feb 08, 2011 3:27 pm

Return to Portable Appliance Testing

Who is online

Users browsing this forum: No registered users and 1 guest