Page 1 of 2

PATGuard 3 Missing Functions

PostPosted: Fri Aug 23, 2013 10:42 am
by safe + sound
Other than dcengineering’s Drag & drop gone and Patguard viewer manual questions, has anyone found more Patguard 2 functions missing from Patguard 3?

Re: PATGuard 3 Missing Functions

PostPosted: Fri Aug 30, 2013 4:48 am
by verstapp
I just tried to print a report [elite, trial copy] to screen, 'program is not responding'.
perhaps it would be useful if someone [Amy?] posted a list of functions that are switched off in the trial version, so as to minimise spurious 'x is broken' posts.
and as for my 'print a report' non-event, perhaps a 'this is turned off in the trial version' message is better than 'program is not responding'.
another thing that seems to have disappeared is editing in treeview. previously it was 'click on item [client, site, whatever], press F2 to hilight and put in edit mode, edit then press enter to save. took ages to update screen, though. now i have to double-click on the item [F8 functionality seems to have disappeared too], edit in the details view, press enter to save, and it takes even longer for the screen to update.

Re: PATGuard 3 Missing Functions

PostPosted: Fri Aug 30, 2013 10:59 am
by Amy Lyons
Hi verstapp

There are no functions turned off in the trial version. The only limitation it has is the time period of 30 days.

Can you please try creating a report using the demo database to see if this works correctly. The demo database is located in the install directory (usually C drive, Program Data (which is a hidden folder), Seaward, PATGuard 3).

I will speak to our Software Engineers with regards to editing in the tree mode as this should work as per PATGuard 2. I do know that due to the new database format some functions of PATGuard 2 (such as drag and drop) did not copy over and so we are in the process of re-developing this functionality. Of course all of this will be available as a free update regardless of whether you are in trail or full version.

Re: PATGuard 3 Missing Functions

PostPosted: Fri Aug 30, 2013 1:09 pm
by verstapp
>30 days
my copy, d/l'd and installed yesterday, today says 12 days to go.
?

Re: PATGuard 3 Missing Functions

PostPosted: Fri Aug 30, 2013 1:54 pm
by Glen Cook
Hi,

Some of the reports are currently taking a long time to be created. This can cause windows to show that the application is not responding. The program will respond once the report has been completed. We are in the process of speeding up this functionality and it will be released as a hotfix.

Glen.

Re: PATGuard 3 Missing Functions

PostPosted: Fri Aug 30, 2013 2:26 pm
by Glen Cook
verstapp wrote:my copy, d/l'd and installed yesterday, today says 12 days to go.


Hi,

The 30 day trial will start from the moment PATGuard is first ran. If it has been uninstalled and reinstalled at a later time, the trial will still run from the original install date.

I'm guessing that someone within your company must have installed PATGuard previously on the same computer (and possibly uninstalled it).

There are no known issues with the trial system.

Glen.

Re: PATGuard 3 Missing Functions

PostPosted: Fri Aug 30, 2013 11:08 pm
by verstapp
>There are no known issues with the trial system
there are now. as i said, my copy was d/l'd, installed thursday eastern australian time on a just-imaged windows 7 box.
>long report times
perhaps if you just copied&pasted the code from patguard plus. my copy takes 10sec max to generate a report.

Re: PATGuard 3 Missing Functions

PostPosted: Sun Sep 01, 2013 5:03 pm
by safe + sound
Glen
I downloaded PG3 on 28 August and I get a message every time I open it, today (1 September) that message says I have 10 days left to evaluate. That has to be an issue.

Reference running reports that contain results or history, if you populate the Site Name and Location Name fields as well as the Client Name it is considerably quicker.

I can't get briefcase files created in PG3 to open in PG2.1

Re: PATGuard 3 Missing Functions

PostPosted: Mon Sep 02, 2013 6:48 am
by verstapp
@amy - i tried the demo database today, report printed instantly [definitely less than 1sec].
so i tried [a copy of] my current [patguard plus] database again, only about 50x the size of the demo [110MB], 'updated' [i say 'updated ' because i notice your database designer still hasn't comprehended the concept of the first normal form] when i first loaded it into Pat3. it once again just sat there with the [win7] hourglass swirling. after 30sec or so i got bored and clicked cancel, at which point it went into its 'preview has stopped responding' routine again. what part of 'cancel' does it not understand?

@S&S - i normally just do my reports on dates because i rarely have a job lasting less than a day, but i tried putting site and location into the report dialogue anyway. no improvement. still taking less than 10sec in patguard plus on xp.

Re: PATGuard 3 Missing Functions

PostPosted: Tue Sep 03, 2013 11:36 am
by Glen Cook
safe + sound wrote:Glen
I downloaded PG3 on 28 August and I get a message every time I open it, today (1 September) that message says I have 10 days left to evaluate. That has to be an issue.


It does seem a little strange that two people are reporting this. We will look into the issue, but it's a difficult problem to track down when we cannot reproduce the problem here.

safe + sound wrote:Reference running reports that contain results or history, if you populate the Site Name and Location Name fields as well as the Client Name it is considerably quicker.


We are aware that some of the database queries are taking a long time to run. The next release of PATGuard (3.0.3) has made improvements in this area and reports should be produced much faster.

safe + sound wrote:I can't get briefcase files created in PG3 to open in PG2.1


PATGuard 3 files are not compatible with PATGuard 2.1

Cheers

Glen.